Merge branch 'stable-3.1'

* stable-3.1:
  Upgrade bazlets to latest stable-3.1 to build with 3.1.7 API
  Upgrade bazlets to latest stable-3.0 to build with 3.0.11 API
  Remove the commented-out snapshot plugin api lines
  Adapt SNAPSHOT plugin api example to the 3.1 version
  Upgrade bazlets to latest stable-3.1
  Prepare for new gerrit_api snapshot version usage
  Upgrade bazlets to latest stable-3.0
  Upgrade bazlets to latest stable-3.0

Change-Id: Ifa01708aedb1b0a0374c4c3e6eb445b2db33f3b3
tree: 70424cb353c10f36c95778cd1f90f1790c91c2a1
  1. .bazelignore
  2. .bazelrc
  3. .bazelversion
  4. .gitignore
  5. .settings/
  6. .travis.yml
  7. BUILD
  8. LICENSE
  9. LICENSE-scribe
  10. README.md
  11. WORKSPACE
  12. bazlets.bzl
  13. external_plugin_deps.bzl
  14. src/
  15. tools/
README.md

Gerrit OAuth2 authentication provider

Build Status

With this plugin Gerrit can use OAuth2 protocol for authentication. Supported OAuth providers:

See the Wiki what it can do for you.

Prebuilt artifacts

Prebuilt binary artifacts are available on release page. Make sure to pick the right JAR for your Gerrit version.

Build

To build the plugin with Bazel, install Bazel and run the following:

  git clone https://gerrit.googlesource.com/plugins/oauth
  cd oauth && bazel build oauth

Install

Copy the bazel-bin/oauth.jar to $gerrit_site/plugins and re-run init to configure it:

  java -jar gerrit.war init -d <site>
  [...]
  *** OAuth Authentication Provider
  ***
  Use Bitbucket OAuth provider for Gerrit login ? [Y/n]? n
  Use Google OAuth provider for Gerrit login ? [Y/n]?
  Application client id          : <client-id>
  Application client secret      : 
                confirm password : 
  Link to OpenID accounts? [true]: 
  Use GitHub OAuth provider for Gerrit login ? [Y/n]? n

Reporting bugs

Make sure to read the FAQ before reporting issues.

License

Apache License 2.0