Drop unneeded dependency on commons-io

After Gerrit core dropped providing a definition for commons-io,
building this plugin failed [1]. Since this plugin's dependency on
commons-io is unneeded anyways, we just drop it to allow building the
plugin again.

[1] The error message was

  Couldn't get dependency '//lib/commons:io' of target '//plugins/branch-network:branch-network__plugin':

. For full logs, see

  http://builds.quelltextlich.at/gerrit/nightly/master/2015-08-06/branch-network.jar.build.stderr.txt
  http://builds.quelltextlich.at/gerrit/nightly/master/2015-08-06/index.html#branch-network.jar

Change-Id: I84237f733b77284f9fbd9cb7715b0f48b0cd6b1b
1 file changed
tree: 337c26f83bcc565f5b4360924774f2b809b0ef8f
  1. .gitignore
  2. BUCK
  3. LICENSE
  4. pom.xml
  5. src/