Remove Java 11 build for Gerrit v3.2

Gerrit v3.2 has been released years ago with Java 8
and the Java 11 release and validation isn't necessarily
required.

Change-Id: Iad4b06d53b9c5e362e7707532a2c29c0be15876c
1 file changed
tree: 871f4d6a3c13d6f03e18f2cdf91ab27b03edd675
  1. .gitignore
  2. Jenkinsfile
  3. README.md
  4. jenkins-docker/
  5. jenkins/
  6. vars/
  7. worker/
  8. yamllint-config.yaml
README.md

Gerrit CI scripts

Providing jobs

This project uses Jenkins Jobs Builder [1] to generate jobs from yaml descriptor files.

To add new jobs reuse existing templates, defaults etc. as much as possible. E.g. adding a job to build an additional branch of a project may be as easy as adding the name of the branch to an existing project.

To ensure well readable yaml-files, use yamllint [2] to lint the yaml-files. Yamllint can be downloaded using Python Pip:

pip3 install yamllint

To run the linter, execute this command from the project's root directory:

yamllint -c yamllint-config.yaml jenkins/**/*.yaml

Yamllint will not fix detected issues itself.

[1] https://docs.openstack.org/infra/jenkins-job-builder/index.html [2] https://pypi.org/project/yamllint/