Merge "Merge branch 'stable-2.16'"
diff --git a/.gitignore b/.gitignore
index 33a7d4b..0cd74ca 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,7 +3,6 @@
 .classpath
 .project
 .settings/
-target/
 .idea/
 *.iml
 /bin/
diff --git a/BUILD b/BUILD
index 658f3da..ba18e42 100644
--- a/BUILD
+++ b/BUILD
@@ -10,9 +10,11 @@
     name = "slack-integration",
     srcs = glob(["src/main/java/**/*.java"]),
     manifest_entries = [
+        "Gerrit-ApiType: plugin",
         "Gerrit-PluginName: slack-integration",
-        "Implementation-Title: slack-integration plugin",
+        "Implementation-Title: Slack Integration",
         "Implementation-URL: https://gerrit-review.googlesource.com/#/admin/projects/plugins/slack-integration",
+        "Implementation-Vendor: Cisco Systems, Inc.",
     ],
     resources = glob(["src/main/resources/**/*"]),
 )
diff --git a/README.md b/README.md
index d828f14..8869778 100644
--- a/README.md
+++ b/README.md
@@ -11,20 +11,15 @@
 -----------
 
 To build the plugin,
-[JDK 1.8](http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html),
-[Maven 3.0.x](http://maven.apache.org/download.cgi) and
-[Ant 1.9.x](https://ant.apache.org/bindownload.cgi) are required.
-Once installed use _mvn_ to build.
+[JDK 1.8](http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html)
+and [Bazel](https://bazel.build/) are required.
+
+Once installed use _bazel_ to build.
 
     cd ./slack-integration
-    mvn install
+    bazel build slack-integration
 
-This command will compile/test and package the resulting artifact.
-
-    cd ./slack-integration
-    mvn package
-
-Once packaged, you can install the _./target/slack-integration.jar_ file into
+Once packaged, you can install the _./bazel-genfiles/slack-integration.jar_ file into
 Gerrit.
 
 
diff --git a/pom.xml b/pom.xml
deleted file mode 100644
index 4d88a1b..0000000
--- a/pom.xml
+++ /dev/null
@@ -1,148 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!--
-  ~ Copyright 2017 Cisco Systems, Inc.
-  ~
-  ~ Licensed under the Apache License, Version 2.0 (the "License"); you may
-  ~ not use this file except in compliance with the License. You may obtain
-  ~ a copy of the License at
-  ~
-  ~ http://www.apache.org/licenses/LICENSE-2.0
-  ~
-  ~ Unless required by applicable law or agreed to in writing, software
-  ~ distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
-  ~ WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
-  ~ License for the specific language governing permissions and limitations
-  ~ under the License.
-  ~
-  -->
-
-<project xmlns="http://maven.apache.org/POM/4.0.0"
-         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
-         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
-    <modelVersion>4.0.0</modelVersion>
-
-    <groupId>com.cisco.gerrit.plugins</groupId>
-    <artifactId>slack-integration</artifactId>
-    <packaging>jar</packaging>
-    <version>3.0-SNAPSHOT</version>
-    <name>Slack Integration Plugin</name>
-
-    <properties>
-        <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
-
-        <gerrit-api-type>plugin</gerrit-api-type>
-        <gerrit-api-version>${project.version}</gerrit-api-version>
-    </properties>
-
-    <build>
-        <plugins>
-            <plugin>
-                <groupId>org.apache.maven.plugins</groupId>
-                <artifactId>maven-jar-plugin</artifactId>
-                <version>2.4</version>
-                <configuration>
-                    <archive>
-                        <manifestEntries>
-                            <Implementation-Vendor>
-                                Cisco Systems, Inc.
-                            </Implementation-Vendor>
-                            <Implementation-URL>
-                                https://gerrit-review.googlesource.com/#/admin/projects/plugins/slack-integration
-                            </Implementation-URL>
-                            <Implementation-Title>
-                                Slack Integration
-                            </Implementation-Title>
-                            <Implementation-Version>
-                                ${project.version}
-                            </Implementation-Version>
-                            <Gerrit-ApiType>
-                                ${gerrit-api-type}
-                            </Gerrit-ApiType>
-                            <Gerrit-ApiVersion>
-                                ${gerrit-api-version}
-                            </Gerrit-ApiVersion>
-                        </manifestEntries>
-                    </archive>
-                    <finalName>${project.artifactId}</finalName>
-                </configuration>
-            </plugin>
-
-            <!--<plugin>-->
-                <!--<groupId>org.apache.maven.plugins</groupId>-->
-                <!--<artifactId>maven-surefire-plugin</artifactId>-->
-                <!--<version>2.18.1</version>-->
-                <!--<configuration>-->
-                    <!--<excludes>-->
-                        <!--<excludes>**/*IntegrationTest.java</excludes>-->
-                    <!--</excludes>-->
-                <!--</configuration>-->
-            <!--</plugin>-->
-
-            <!--<plugin>-->
-                <!--<groupId>org.apache.maven.plugins</groupId>-->
-                <!--<artifactId>maven-failsafe-plugin</artifactId>-->
-                <!--<version>2.18.1</version>-->
-                <!--<configuration>-->
-                    <!--<includes>-->
-                        <!--<include>**/*IntegrationTest.java</include>-->
-                    <!--</includes>-->
-                <!--</configuration>-->
-            <!--</plugin>-->
-
-            <plugin>
-                <groupId>org.apache.maven.plugins</groupId>
-                <artifactId>maven-compiler-plugin</artifactId>
-                <version>3.8.0</version>
-                <configuration>
-                    <source>1.8</source>
-                    <target>1.8</target>
-                </configuration>
-            </plugin>
-        </plugins>
-    </build>
-
-    <dependencies>
-        <dependency>
-            <groupId>com.google.gerrit</groupId>
-            <artifactId>gerrit-${gerrit-api-type}-api</artifactId>
-            <version>${gerrit-api-version}</version>
-            <scope>provided</scope>
-        </dependency>
-
-        <dependency>
-            <groupId>org.slf4j</groupId>
-            <artifactId>slf4j-simple</artifactId>
-            <version>1.7.9</version>
-            <scope>test</scope>
-        </dependency>
-
-        <dependency>
-            <groupId>junit</groupId>
-            <artifactId>junit</artifactId>
-            <version>4.11</version>
-            <scope>test</scope>
-        </dependency>
-
-        <dependency>
-            <groupId>org.mockito</groupId>
-            <artifactId>mockito-all</artifactId>
-            <version>1.10.19</version>
-            <scope>test</scope>
-        </dependency>
-
-        <dependency>
-            <groupId>org.powermock</groupId>
-            <artifactId>powermock-module-junit4</artifactId>
-            <version>1.6.2</version>
-            <scope>test</scope>
-        </dependency>
-
-        <dependency>
-            <groupId>org.powermock</groupId>
-            <artifactId>powermock-api-mockito</artifactId>
-            <version>1.6.2</version>
-            <scope>test</scope>
-        </dependency>
-    </dependencies>
-</project>